• 欢迎访问 追梦人 网站

修改TP5 Query.php文件支持PHP7.4版本

PHP dreamren 来源:TP论坛 4周前 (03-12) 27次浏览 已收录 0个评论 扫描二维码

PHP7.4 不再支持使用大括号访问数组以及字符串的偏移.如果在 PHP7.4 以后的代码中,还是使用大括号来获取的话,那么就会抛出如下错误信息:Array and string offset access syntax with curly braces is deprecated
因此想让您的 TP5 支持 php7.4 则需要修改一处代码 thinkphp\library\think\db\Query.php,  TP 不同版本对应行数可能不同,如 tp5.0.9 为 370 行,TP5.0.24 为 399 行


追梦人博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:修改TP5 Query.php文件支持PHP7.4版本
网站部分内容来源网络,如有侵犯您的权益,请联系我们,我们会第一时间处理您的反馈信息,谢谢!!!
喜欢 (1)
[dreamren@foxmail.com]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址